OMAPL138基于SYSLINK的双核通信问题 - OMAP-L138 - 嵌入式开发者社区 - 51ele.net
设为首页收藏本站

嵌入式开发者社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 315|回复: 1

[未解决] OMAPL138基于SYSLINK的双核通信问题

[复制链接]

1

主题

1

帖子

1018

积分

金牌会员

Rank: 6Rank: 6

积分
1018
发表于 2020-10-17 22:00:06 | 显示全部楼层 |阅读模式 |文章模式
本帖最后由 136988129 于 2020-10-18 11:30 编辑 ! z  @1 @$ B' r6 ?( y
/ l, b' V2 q: c) G
我现在跑程序时出故障了,打印如下
: _' g1 N) @* h% z Assertion at Line no: 1973 in /home/teddy/davinci/mcsdk-work/syslink_2_21_01_05/packages/ti/syslink/utils/hlos/knl/Linux/../../../../../../ti/syslink/family/hlos/knl/omapl1xx/Platform.c: (!entry.isValid) : failed9 s- B3 |0 ?- Q8 q4 R. {) q& u
[  142.087755] Assertion at Line no: 2064 in /home/teddy/davinci/mcsdk-work/syslink_2_21_01_05/packages/ti/syslink/utils/hlos/knl/Linux/../../../../../../ti/syslink/family/hlos/knl/omapl1xx/Platform.c: (!_SharedRegion_isStarted()) : failed
' K9 r, h: [! k: L5 E
+ w+ _% \" |6 t  qlinux系统 起来之后 会启动一个定时脚本,脚本每隔2分钟会运行 应用程序   程序运行后 fpga采集数据传送到arm  然后程序退出  等下一次采集   程序崩溃一般出现在10分钟 之后    我想问一下 这个是否跟syslink执行和退出的有关  这个应该怎么改
我知道答案 本帖寻求最佳答案回答被采纳后将获得系统奖励0 , 目前已有1人回答
最近访问 头像模式 列表模式
回复

使用道具 举报

3

主题

835

帖子

3383

积分

创龙

Rank: 8Rank: 8

积分
3383
发表于 2020-10-19 20:22:09 | 显示全部楼层
目前看不出具体原因,如果怀疑跟syslink执行和退出有关,就可以尝试把脚本每隔2分钟会运行改成持续运行程序10分钟以上,看会不会出现同样的问题。
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则  回帖提醒

QQ|手机版|小黑屋|嵌入式开发者社区 ( 粤ICP备15055271号-1  

GMT+8, 2020-12-5 16:05 , Processed in 0.061941 second(s), 34 queries .

Powered by Discuz! X3.2

© 2001-2015 Comsenz Inc.

快速回复 返回顶部 返回列表