C6678 仿真器无法连接 - TMS320C6678 - 嵌入式开发者社区 - 51ele.net
设为首页收藏本站

嵌入式开发者社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 215|回复: 4

[已解决] C6678 仿真器无法连接

[复制链接]

1

主题

4

帖子

1021

积分

金牌会员

Rank: 6Rank: 6

积分
1021
发表于 2018-11-14 17:34:29 | 显示全部楼层 |阅读模式
今天刚刚试着用仿真器进行仿真,尝试了用JTAG连接TL6678-EasyEVM,出现如下报错:
C66xx_0:Trouble Writing Memory Block at 0x8000 on Page 0 of Length 0x7040: (Error -1190 @ 0x8000) Unable to access device memory. Verify that the memory address is in valid memory. If error persists, confirm configuration, power-cycle board, and/or try more reliable JTAG settings (e.g. lower TCLK). (Emulation package file:///C:\Users\liu\AppData\Local\Temp\%W@GJ$ACOF(TYDYECOKVDYB.png8.0.27.9)

C66xx_0: File Loader: Verification failed: Target failed to write 0x00008000
C66xx_0: GEL: File: C:\Users\liu\workspace_v8\Hello World\Debug\Hello World.out: Load failed.

用的CCSv8,驱动安装了,不知道是不是板子需要进行什么设置才能进行仿真?

最佳答案

您的gel文件是使用我司提供的吗?
最近访问 头像模式 列表模式
回复

使用道具 举报

4

主题

188

帖子

1692

积分

广州创龙

Rank: 8Rank: 8

积分
1692
发表于 2018-11-14 17:45:29 | 显示全部楼层
您的gel文件是使用我司提供的吗?
回复 支持 反对

使用道具 举报

1

主题

4

帖子

1021

积分

金牌会员

Rank: 6Rank: 6

积分
1021
 楼主| 发表于 2018-11-14 20:02:48 | 显示全部楼层
本帖最后由 mmchest 于 2018-11-14 20:10 编辑

我按照开发板光盘里的用户手册进行设置,test connection显示能成功连接,但是加载各gel文件debug时就报错了,另外ccs8和ccs5界面和设置都不太一样,debug窗口似乎没法看到八个核(也可能是由于debug报错导致?)
回复 支持 反对

使用道具 举报

1

主题

4

帖子

1021

积分

金牌会员

Rank: 6Rank: 6

积分
1021
 楼主| 发表于 2018-11-14 20:32:15 | 显示全部楼层
tronlong-gxd 发表于 2018-11-14 17:45
您的gel文件是使用我司提供的吗?

我找到了ccsv8加载gel文件的方法,在target configuration->advance,点击一个核,右边出现initialization script,后边的browse选择gel文件路径。加载创龙提供的gel文件后debug窗口能看到八个核了,但是又出现了新错误
C66xx_0: Trouble Writing Register PC: (Error -1176 @ 0xEA40) Unable to access device memory. Verify that the memory address is in valid memory. If error persists, confirm configuration, power-cycle board, and/or try more reliable JTAG settings (e.g. lower TCLK). (Emulation package 8.0.27.9)
回复 支持 反对

使用道具 举报

1

主题

4

帖子

1021

积分

金牌会员

Rank: 6Rank: 6

积分
1021
 楼主| 发表于 2018-11-14 21:41:53 | 显示全部楼层
tronlong-gxd 发表于 2018-11-14 17:45
您的gel文件是使用我司提供的吗?

我找到问题所在了,是因为没有按照顺序操作
要先build project生成.out文件,再加载.gel文件,debug初始化,run->load project打开刚刚生成的.out文件,运行。
自己尝试新建了一个工程,使用仿真器运行成功

非常感谢您的回复
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则  回帖提醒

QQ|手机版|小黑屋|嵌入式开发者社区 ( 粤ICP备15055271号-1  

GMT+8, 2019-1-24 17:48 , Processed in 0.185696 second(s), 44 queries .

Powered by Discuz! X3.2

© 2001-2015 Comsenz Inc.

快速回复 返回顶部 返回列表