基于k2g做qt的开发遇到的问题 - 66AK2Gx - 嵌入式开发者社区 - 51ele.net
设为首页收藏本站

嵌入式开发者社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 535|回复: 2

[未解决] 基于k2g做qt的开发遇到的问题

[复制链接]

13

主题

28

帖子

355

积分

中级会员

Rank: 3Rank: 3

积分
355
发表于 2018-8-27 17:25:10 | 显示全部楼层 |阅读模式
环境是Ubuntu14.04,qt的安装包是OMAPL138网盘里的qt4.8.3
1.安装g++,具体这样的结果对不对

2.按照基于L138的linux Qt的入门开发教程资料配置首先安装ARM端的qt,配置都没有报错。但是到了make的时候出错了,具体如下图


说是没有找到arm-none-linux-gnueabi-g++这个东西

本帖子中包含更多资源

您需要 登录 才可以下载或查看,没有帐号?立即注册

x
最近访问 头像模式 列表模式
回复

使用道具 举报

3

主题

255

帖子

913

积分

广州创龙

Rank: 8Rank: 8

积分
913
发表于 2018-8-28 09:14:04 | 显示全部楼层
1、从您的截图可见您这里是已经安装了g++的了。请检查您的交叉编译工具链是否已经安装了?查看一下您的交叉编译工具链版本号,输入指令:arm-none-linux-gnueabi-gcc -v
2、假如运行出错,请先运行"make confclean"清理源码,接着重复上一小节的配置命令,再重新执行"make -j4 && make install"。
回复 支持 0 反对 1

使用道具 举报

4

主题

188

帖子

1698

积分

广州创龙

Rank: 8Rank: 8

积分
1698
发表于 2018-8-28 09:11:09 | 显示全部楼层
您好,目前66AK官方是不支持Qt,需要您自行移植,建议您参考qt官方资料进行移植,链接如下:http://doc.qt.io/qt-5/configure-options.html  
                           http://doc.qt.io/qt-5/embedded-l ... g-a-specific-device
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则  回帖提醒

QQ|手机版|小黑屋|嵌入式开发者社区 ( 粤ICP备15055271号-1  

GMT+8, 2019-3-24 18:06 , Processed in 0.133978 second(s), 29 queries .

Powered by Discuz! X3.2

© 2001-2015 Comsenz Inc.

快速回复 返回顶部 返回列表