TMS320C6678中K1例程中GE以太网初始化MDIO问题 - TMS320C6678 - 嵌入式开发者社区 - 51ele.net
设为首页收藏本站

嵌入式开发者社区

 找回密码
 立即注册

QQ登录

只需一步,快速开始

查看: 543|回复: 0

[未解决] TMS320C6678中K1例程中GE以太网初始化MDIO问题

[复制链接]

1

主题

1

帖子

1019

积分

金牌会员

Rank: 6Rank: 6

积分
1019
发表于 2018-1-8 12:05:13 | 显示全部楼层 |阅读模式
6678以太网初始化PHY芯片
如果图片加载不出来的话直接看超链接地址吧!!!!!!!
(1)TMS320C6678如何通过MDIO初始化PHY芯片???有没有程序可以参考。比如根据硬件设置来修改程序中的PHY地址????
(2)将例程做了如下修改:修改DDR3初始化,主频配成1G时钟,Serdes的参考时钟为修改为250M。
分别测试了GE_TEST_EMAC_LOOPBACK模式、GE_TEST_SGMII_LOOPBACK模式、GE_TEST_SERDES_LOOPBACK模式都能通过。而且打印结果信息。测试时其他的配置都相同。
配置如下:Ethernet_Mode ethernet_mode = ETHERNET_AUTO_NEGOTIAT_MASTER;
GE_Port_Connection port_connect[GE_NUM_ETHERNET_PORT]=
{

GE_PORT_CABLE_CONNECT ,//SGMII port 0     我们的板卡用的是这个端口
GE_PORT_NOT_USED//SGMII port 1
};
测试GE_TEST_DSP0_TO_DSP1时不能通过初始化。
发现MDIO初始化后的寄存器都是0 。下面是MDIO的初始化程序。
C:\Users\Administrator\Desktop\1.jpg
(1)在6678评估板上运行的MDIO寄存器结果:
C:\Users\Administrator\Desktop\图片3.png
(2)在我们自己的板卡上运行的MDIO寄存器结果:
C:\Users\Administrator\Desktop\图片2.png
(1)对于上面的现象可能是什么原因导致的???硬件问题或是软件问题最好能具体点。。
(2)如何在程序中修改PHY芯片的PHY地址???例程中评估板的PHY地址是0x1如果想修改为0x7,在程序中该怎么修改???
(3)在评估板上运行DSP和PC之间的通信程序是可以的。但是在我的板卡上就出现如下的问题:
C:\Users\Administrator\Desktop\22.png
我看了gpSGMII_regs->STATUS_REG=0x30,
(1)我现在测试的板卡的PHY芯片的物理地址是7。出现上面的原因是不是因为修改了PHY芯片地址的原因??????
(2)程序卡死在这里是不是因为MDIO没有初始化成功导致的?????
我知道答案 本帖寻求最佳答案回答被采纳后将获得系统奖励0 , 目前已有0人回答
最近访问 头像模式 列表模式
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则  回帖提醒

QQ|手机版|小黑屋|嵌入式开发者社区 ( 粤ICP备15055271号-1  

GMT+8, 2018-12-19 06:17 , Processed in 0.146666 second(s), 32 queries .

Powered by Discuz! X3.2

© 2001-2015 Comsenz Inc.

快速回复 返回顶部 返回列表